How can I send outgoing emails from Sharepoint in CloudShare?
Answered

Comments

8 comments

  • Avatar
    Peter Franks

    Hi Fahad, 

    When setting up outgoing emails from SharePoint you would handle this in much the same way as you would with any standard installation of CloudShare. This post from Microsoft's Technet should be a helpful guide.

    You can configure an SMTP server in your CloudShare environment (IIS includes an SMTP server), or you can use any cloud email provider such as Gmail assuming you have an account. Just ensure you enable SMTP authentication and do not have an open relay.

    0
    Comment actions Permalink
  • Avatar
    Bruce Altner

    Scott:

    Does this work for trial accounts? I've followed all the steps in the TechNet article to get the SMTP server running (in IIS) but don't know what to use for the SMTP server name in Central Admin.  I tried mail.sp2010.spdom.loc and a few others but none seem to work.  What is a valid SMTP server name for my virtual machine?

    0
    Comment actions Permalink
  • Avatar
    Fahad Sidheekh

    Hi Bruce,

    You can go through this article.

    This helps you in setting up the mail set up

    http://pitstopsharepoint.blogspot.com/2012/04/configuring-outgoing-email-in.html

    Thanks

    Fahad.

    0
    Comment actions Permalink
  • Avatar
    Bruce Altner

    Fahad:

    Thanks for the reply, but it is still not sending out alerts or email from workflows. I had tried the gmail/POP thing already, without success.  The article that I found suggested two things not in your writeup:

    1.  On the SMTP virtual server propertied/delivery panel click Outbound connections button and change the port to 587

    1. On the SMTP virtual server propertied/delivery panel click Advanced button and set the smarthost to my gmail account.

    Since you did not mention these steps I skipped them but also got the same result.

    One point:  For the smtp server name you say to use the "computer" name.  I am using the fully-qualified name, e.g., sp2010.spdom.loc. 

    Also, gmail POP is enabled but so is IMAP.  I don't think this is an issue but I could be wrong.

     

    Thanks,

    Bruce

    0
    Comment actions Permalink
  • Avatar
    Bruce Altner

    Looks like I got it to work using the extra two settings. Thanks for the assist!

    Bruce

    0
    Comment actions Permalink
  • Avatar
    NewUser Web

    I have the SMTP server name as follows: SP2010APP.AD2008R2.loc

     

    Followed instruction as per the link >>> https://support.cloudshare.com/entries/21310066-how-can-i-send-outg...

    But when I test trying to send an outbound email, it doesn't send.

     

    I tested using the following powershell script as well as setting up an AD user with external email address and sending a welcome message.

    $site = New-Object Microsoft.SharePoint.SpSite(" http://sp2010app:3695")

    $web = $site.OpenWeb("")

    $sent = [Microsoft.Sharepoint.Utilities.SpUtility]::SendEmail($web,0,0," Validuser@Gmail.com", "Test mail subject","test mail body")

    $sent

     

    I get a result as "False" and the email was not sent/received. Somebody please help.

    0
    Comment actions Permalink
  • Avatar
    Aladdin Anvar

    Scott,

    In the link you have provided from Microsoft  http://technet.microsoft.com/en-us/library/cc263462.aspx#section3 and in

    To configure the SMTP service

     section (number 7) is written:

    7. In the Authentication dialog box, verify that Anonymous access is selected.

    Should we follow the above? I cannot send email unless I do the above.

     

    0
    Comment actions Permalink
  • Avatar
    Tzvika Zitzman

    @Aladdin,

    This is quite a poor security design by Microsoft. You can enable anonymous access as long as your SMTP server is configured only to relay emails from the local machine (127.0.0.1)

    0
    Comment actions Permalink

Please sign in to leave a comment.