Profile picture url is not visible with external access
Answered

Comments

5 comments

  • Avatar
    Peter Franks

    Hi Bert, 

    Thanks for posting your question!  

    We actually had someone with a similar question about configuring Alternate Access Mappings not too long ago, so have a look at that link.  

    I also found this info which provides a deeper walkthrough on how to make your SharePoint site externally available.  The link you would need to use as your host name is the Web Access URL which looks like this: http://uvo123456.env.cloudsh...  For a little more info on Web Access and what it does, check out our Web Access walkthrough.  

    Thanks!

    0
    Comment actions Permalink
  • Avatar
    Bert Santema

    Thanks for the documentation links. It turned out I didn't quite understand the Sharepoint site setup.

    Port 8080 is a separate site called "My Site". For some reason Sharepoint uploads profile pictures in this site and serves them from it as well (on port 8080!). By default a new Cloudshare enviroment only provides the base Sharepoint site (hosted on port 80) on the external url. So in order to make the profile pictures available on the external url I had to do "Add Internal URLs" (sounds weird, I know). For the url I entered my external url with :8080 appended and specified Internet as the zone. Now Sharepoint is externally accessible on port 8080 and so the profile pictures show.

    Seems to me that it would make sense to add the mapping for 8080 by default when setting up a new Sharepoint environment, but maybe I'm still not seeing the complete picture ;-)

    0
    Comment actions Permalink
  • Avatar
    Peter Franks

    Hi Bert, thanks for the extra info and I'm glad you got it working.  

    I spoke with one of our in-house SharePoint experts who mentioned MySite's default port of 8080 is typically the best practice as it's involved in a lot of different parts of a SP farm.  Your best option would be to create any new web apps in the 8000-8010 port range or delete the current port 80 web app and make a new one.  

    0
    Comment actions Permalink
  • Avatar
    Bert Santema

    Good to know that port 8080 for MySite is best practice, but I'm not sure I'm following you with the rest. I don't need to create any new applications, I just created a webpage that includes the profile picture. The problem was that the webpage was served on port 80 which is by default accessible on the external url. The profile picture is served on port 8080 which was not accessible on the external url so the picture never showed up. Adding the mapping as described solved this for me and that was my suggestion: add the external mapping for port 8080 by default. I did not mean to suggest to alter the MySite port.

    0
    Comment actions Permalink
  • Avatar
    Peter Franks

    Sorry Bert, I think I misunderstood you originally.  But it sounds like you're good to go.  Let me know if there is anything else we can help with.  

    0
    Comment actions Permalink

Please sign in to leave a comment.