How do I directly access alternate WebAccess Ports
Answered

Comments

8 comments

  • Avatar
    Peter Franks

    Hi Rajit,

    Great question and one that we often get.  Have you tried setting up the various sites you need in SharePoint and assigning the ports there and setting up the Alternate Access Mappings, then mirroring the settings in IIS Bindings as below? 

    IIS_bindings.png

    If you set up your sites and then assign each one a different port from our list of opened ports (80, 443, 3695, 8000-8010 & 8080) then you should be able to use the Web Access URL and port number to direct your users directly to the site you want them to see. 

    On a side note, I noticed you are running SP Foundation Server.  You may have a better experience by running one of our SP Enterprise versions with more functionality. 

    SP_templates.png

    Also feel free to have a look at our pre-built farms in the SharePoint Showcase from our community. 

    0
    Comment actions Permalink
  • Avatar
    Rajit Kishor Patel

    Scott, thanks for this information.

    However, just to be clear about a few things:

    SharePoint was just testing something out; we're not actually using that machine, and I will be removing it from our environment.

    We have the other machine primarily setup, and our main usage is to be able to fire-up a collaborative development/testing environment (most of our team is not in same location) that we can work together through.  

    I have been able to get the IIS and everything set up for our sites.  However, if I try to bind it to a port other than 80 (using one of the identified-permitted ports such as 8080), and I try to access the site directly from the URL it never works.

     

    At core the main question is this

    How do I actually access these permitted alternate ports directly from the external web access url?

    (as putting a port identifier URL:8080 does not work, but just brings an error)

     

    From your post above:

    If you set up your sites and then assign each one a different port from our list of opened ports (80, 443, 3695, 8000-8010 & 8080) then you should be able to use the  Web Access URL and port number to direct your users directly to the site you want them to see. 

    This is what i'm trying to do, but I can't indicate the port number.

    If you follow-up directly, I will send you examples of URLs that I'm trying to use.

    0
    Comment actions Permalink
  • Avatar
    Tzvika Zitzman

    Hi Rajit,

    I suggest checking your local firewall settings on the server and ensure inbound HTTP connections to the Web Access ports are allowed.

     

    0
    Comment actions Permalink
  • Avatar
    Rajit Kishor Patel

    Scott / Avi,

    Sorry for taking so long to respond; other work had taken me away from this for some time.  However, I did alter the Local Firewall Settings on the Server and was able to successfully connect through the permitted alternate/additional WebAccess Ports.  This is exactly what we needed!

    Thanks for your help... this is now completed!

    0
    Comment actions Permalink
  • Avatar
    Peter Franks

    No problem Rajit, thanks for letting us know!.  I'm glad it's working for you now.  

    0
    Comment actions Permalink
  • Avatar
    Bruce Altner

    Hi:

    I have a similar need but much simpler.  Using Web Access I want to get to a different site collection than the one on the root URL (/sp2010/sites/SiteName).  But it is the same port (80).  When I try Web access with the root site collection it works fine:  http://xxxxxx.env.cloudshare.com/.  However, http://xxxxxx.env.cloudshare.com/sites/SiteName does not work (status 404).  What is missing in the mapping between the local host name of sp2010 and the internate URL of http://xxxxxx.env.cloudshare.com?

    Thanks,

    Bruce

    0
    Comment actions Permalink
  • Avatar
    Peter Franks

    Hi Bruce, I'm not the best when it comes to SharePoint configs but would having different sites set up on the different ports we have open work for this?

    Then mimicing the settings in IIS?  

    Also, this post from Microsoft and this blog may help.  

     

    0
    Comment actions Permalink
  • Avatar
    Peter Franks

    If anyone runs into similar problems like this, it can be a tricky one and comes up often.  

    90% of these types of issues can be sourced back to Alternate Access Mappings and IIS.  So when in doubt, check that the Web Access URL (or Vanity URL) is assigned to your site in SharePoint AAMs and in IIS.  

    Web Access and Vanity URLs are pretty dynamic, so you may not always need to update your standard URL with the Vanity version in AAMs & IIS - but it's good practice to check.  

    0
    Comment actions Permalink

Please sign in to leave a comment.